资料下载

×

注意

该论坛处于只读模式。
Welcome, 来宾
Username: Password: Remember me
  • 页:
  • 1

TOPIC: 3845路由器上的Cisco CCME 8.6无法正常工作

3845路由器上的Cisco CCME 8.6无法正常工作 6 years 7 months ago #38522

首先让我说我绝对不是语音专家。我设法让软电话注册X-Lite和Zoiper都没有问题。但是,我无法注册任何Cisco Hard电话。我有以下电话。

思科7941 SIP
2 思科公司 7942 SCCP我想最终将它们转换为SIP
2个Cisco 7960 SCCP

我的理解是正确的,因为语音寄存器为SIP时ephone-dn用于SCCP吗?

SCCP电话会启动,但看起来好像联系了呼叫管理器,因为它们具有2000扩展名,并且从我的配置中可以看到所有内容都是4xxx。 SIP电话7941引导请求term41.default.loads。我相信它会得到。我也进行了数据包捕获。附件。

任何帮助将不胜感激。这是针对实验室环境的
Config
cme8.6>
cme8.6>enable
cme8.6#sh run
Building configuration...


Current configuration : 9933 bytes
!
! Last configuration change at 10:58:43 MDT Thu May 1 2014
! NVRAM config last updated at 10:58:45 MDT Thu May 1 2014
! NVRAM config last updated at 10:58:45 MDT Thu May 1 2014
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service 密码-encryption
!
hostname cme8.6
!
boot-start-marker
boot system flash c3845-adventerprisek9-mz.151-4.M5.bin
boot-end-marker
!
!
!
aaa new-model
!
!
!
!
!
!
!
aaa session-id common
!
clock timezone MST -7 0
clock summer-time MDT recurring
!
dot11 syslog
ip source-route
!
ip cef
!
!
!
ip dhcp pool VoIP_Test_Pool
 network 10.250.0.0 255.255.254.0
 选项150 ip 10.250.0.57
 default-router 10.250.0.57
!
!
no ip domain lookup
ip domain name fnetlab.private
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
voice-card 0
!
!
!
voice service voip
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 supplementary-service h450.12
 sip
  registrar server
!
voice class codec 1
 codec preference 1 g729r8
 codec preference 2 g711ulaw
!
!
voice register global
 mode cme
 source-address 10.250.0.57 port 5060
 max-dn 720
 max-pool 262
 load 7942 SIP42.9-2-1S
 load 7941 SIP41.9-2-1S
 authenticate register
 authenticate realm foo
 tftp-path flash:
 file text
 create profile sync 0008452245893998
 video
!
voice register dn  1
 number 4001
 name 4001
 no-reg
 label Kris A
!
voice register dn  2
 number 4002
 name 4002
 no-reg
 label Kris A 2
!
voice register dn  10
 number 4010
 name 40010
 no-reg
 label Gordon Dell Laptop
!
voice register dn  20
 number 4020
 name 4020
 no-reg
 label Gordon VMWare 1
!
voice register dn  30
 number 4030
 name 4030
 no-reg
 label Gordon VMWare 2
!
voice register dn  40
 number 4040
 name 4040
 no-reg
 label Gordon HW Probe 1
!
voice register dn  50
 number 4050
 name 4050
 no-reg
 label Kevin Dell T3500
!
voice register dn  60
 number 4060
 name 4060
 no-reg
 label Kevin Dell E6410
!
voice register dn  70
 number 4070
 name 4070
 no-reg
 label Kevin Dell M6300
!
voice register dn  205
 number 4205
 name 4205
 no-reg
 label Gordon B C7942 SIP
!
voice register dn  210
 number 4210
 name 4210
 label Kevin L 7942 SIP
!
voice register dn  215
 number 4215
 name 4215
 label Kris A 7941 SIP
!
voice register pool  1
 id mac 685B.359A.CDB0
 number 1 dn 1
 voice-class codec 1
 用户名 4001 密码 4001
!
voice register pool  2
 id mac 000C.29DF.9F70
 number 1 dn 2
 voice-class codec 1
 用户名 4002 密码 4002
!
voice register pool  10
 id mac F01F.AF25.2908
 number 1 dn 10
 voice-class codec 1
 用户名 4010 密码 4010
!
voice register pool  20
 id mac 0050.56C0.0001
 number 1 dn 20
 voice-class codec 1
 用户名 4020 密码 4020
!
voice register pool  30
 id mac 0050.56C0.0008
 number 1 dn 30
 voice-class codec 1
 用户名 4030 密码 4030
!
voice register pool  40
 id mac 00C0.1701.0206
 number 1 dn 40
 voice-class codec 1
 用户名 4040 密码 4040
!
voice register pool  50
 id mac B8AC.6F95.51A3
 number 1 dn 50
 voice-class codec 1
 用户名 4050 密码 4050
!
voice register pool  60
 id mac 5C26.0A1F.B7BB
 number 1 dn 60
 voice-class codec 1
 用户名 4060 密码 4060
!
voice register pool  70
 id mac 001C.232F.9236
 number 1 dn 70
 voice-class codec 1
 用户名 4070 密码 4070
!
voice register pool  205
 id mac 0025.8416.BEE9
 type 7942
 number 1 dn 205
 voice-class codec 1
 用户名 4205 密码 4205
!
voice register pool  210
 id mac 0023.5E18.9B3F
 type 7942
 number 1 dn 210
 voice-class codec 1
 用户名 4210 密码 4210
!
voice register pool  215
 id mac 001E.138C.A191
 type 7941
 number 1 dn 215
 voice-class codec 1
 用户名 4215 密码 4215
!
!
!
!
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-1612486836
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-1612486836
 revocation-check none
 rsakeypair TP-self-signed-1612486836
!
!
crypto pki certificate chain TP-self-signed-1612486836
 certificate self-signed 01
  3082024E 308201B7 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 31363132 34383638 3336301E 170D3134 30343235 31393036
  33355A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 36313234
  38363833 3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100C28D 74A783B5 DEE733FB 456811F9 7A019F0E E0EE8580 EB840C7D 15410DF8
  24841943 EF7A1844 B28D6B71 C68833D3 C577325E 6BC1F1BC 1B503575 BEA82E5A
  21F52DEE CC3EE31C A57F1B91 DAEAAC5B A7AA8229 3FBD5816 8DB47686 CE431AE3
  0B4EB211 93AD93C0 D7685AB7 E24141E0 0FBF5DC0 35C8F314 70DF0700 E79C9713
  51110203 010001A3 76307430 0F060355 1D130101 FF040530 030101FF 30210603
  551D1104 1A301882 16636D65 382E362E 666E6574 6C61622E 70726976 61746530
  1F060355 1D230418 30168014 B3333567 4C464AA8 1694AF90 AFD0F49F 7945D97B
  301D0603 551D0E04 160414B3 3335674C 464AA816 94AF90AF D0F49F79 45D97B30
  0D06092A 864886F7 0D010104 05000381 81006EC6 C9B6D557 461926AF F038149A
  52AE4084 26FB5281 B6A6111D CE5C6101 E0A06D7B 943D8CAD FAB2BEE4 F5E96AE8
  5FC5FDC1 72F9AB6C 9211544F F7018B2B A16B2BB5 9247FB69 A78DC31B BCAF01C4
  06A5AE2B AA078BAB 86C1DF31 1F85FE8D B2036B85 CCE966DF 3C9B622D 077ED840
  A80CBE85 C48682C2 B6E646F2 1AF14388 1A9A
        quit
!
!
license udi pid CISCO3845-MB sn FOC15210MMY
username Admin privilege 15 密码 0 fnet150
username  思科公司  privilege 15 密码 0  思科公司 
!
redundancy
!
!
ip ssh version 2
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 10.250.0.57 255.255.254.0
 duplex auto
 speed auto
 media-type rj45
!
interface GigabitEthernet0/1
 ip address dhcp
 shutdown
 duplex auto
 speed auto
 media-type rj45
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http path flash:/cme-gui-8.6.0
!
!
!
!
!
!
!
!
tftp-server flash:/Phones/P0030801SR02.sbn alias P0030801SR02.sbn
tftp-server flash:/Phones/P0030801SR02.txt alias P0030801SR02.txt
tftp-server flash:/Phones/P0030801SR02.bin alias P0030801SR02.bin
tftp-server flash:/Phones/P0030801SR02.loads alias P0030801SR02.loads
tftp-server flash:/Phones/P0030801SR02.sb2 alias P0030801SR02.sb2
tftp-server flash:/Phones/P003-8-12-00.sbn alias P003-8-12-00.sbn
tftp-server flash:/Phones/OS79XX.TXT alias OS79XX.TXT
tftp-server flash:/Phones/P0S3-8-12-00.loads alias P0S3-8-12-00.loads
tftp-server flash:/Phones/P0S3-8-12-00.sb2 alias P0S3-8-12-00.sb2
tftp-server flash:/Phones/P003-8-12-00.bin alias P003-8-12-00.bin
tftp-server flash:/Phones/cnu41.9-2-1TH1-13.sbn alias cnu41.9-2-1TH1-13.sbn
tftp-server flash:/Phones/cvm41sip.9-2-1TH1-13.sbn alias cvm41sip.9-2-1TH1-13.sbn
tftp-server flash:/Phones/dsp41.9-2-1TH1-13.sbn alias dsp41.9-2-1TH1-13.sbn
tftp-server flash:/Phones/jar41sip.9-2-1TH1-13.sbn alias jar41sip.9-2-1TH1-13.sbn
tftp-server flash:/Phones/SIP41.9-2-1S.loads alias SIP41.9-2-1S.loads
tftp-server flash:/Phones/term41.default.loads alias term41.default.loads
tftp-server flash:/Phones/term61.default.loads alias term61.default.loads
tftp-server flash:/Phones/apps41.9-2-1TH1-13.sbn alias apps41.9-2-1TH1-13.sbn
tftp-server flash:/Phones/cvm41sccp.9-2-1TH1-13.sbn alias cvm41sccp.9-2-1TH1-13.sbn
tftp-server flash:/Phones/jar41sccp.9-2-1TH1-13.sbn alias jar41sccp.9-2-1TH1-13.sbn
tftp-server flash:/Phones/SCCP41.9-2-1S.loads alias SCCP41.9-2-1S.loads
tftp-server flash:/Phones/cnu42.9-2-1TH1-13.sbn alias cnu42.9-2-1TH1-13.sbn
tftp-server flash:/Phones/cvm42sccp.9-2-1TH1-13.sbn alias cvm42sccp.9-2-1TH1-13.sbn
tftp-server flash:/Phones/dsp42.9-2-1TH1-13.sbn alias dsp42.9-2-1TH1-13.sbn
tftp-server flash:/Phones/jar42sccp.9-2-1TH1-13.sbn alias jar42sccp.9-2-1TH1-13.sbn
tftp-server flash:/Phones/SCCP42.9-2-1S.loads alias SCCP42.9-2-1S.loads
tftp-server flash:/Phones/term42.default.loads alias term42.default.loads
tftp-server flash:/Phones/term62.default.loads alias term62.default.loads
tftp-server flash:/Phones/apps42.9-2-1TH1-13.sbn alias apps42.9-2-1TH1-13.sbn
tftp-server flash:/Phones/jar42sip.9-2-1TH1-13.sbn alias jar42sip.9-2-1TH1-13.sbn
tftp-server flash:/Phones/SIP42.9-2-1S.loads alias SIP42.9-2-1S.loads
tftp-server flash:/Phones/cvm42sip.9-2-1TH1-13.sbn alias cvm42sip.9-2-1TH1-13.sbn
!
!
!
control-plane
!
!
!
!
mgcp profile default
!
!
!
sip-ua
!
!
!
telephony-service
 max-ephones 262
 max-dn 720
 ip源地址 10.250.0.249端口5080
 system message  思科公司  VoIP CCMEV8.6
 load 7941 SIP41.9-2-1S
 load 7942 SCCP42.9-2-1S
 time-format 24
 max-conferences 12 gain -6
 dn-webedit
 time-webedit
 transfer-system full-consult
 create cnf-files version-stamp 7960 May 01 2014 10:58:20
!
!
ephone-dn  1
 number 4150
 label 4150
 name 4150
 allow watch
 hold-alert 30 originator
!
!
ephone-dn  150
 number 4150
 label 4150
 name 4150
 allow watch
 hold-alert 30 originator
!
!
ephone-dn  155
 number 4155
 label 4155
 name 4155
 allow watch
!
!
ephone-dn  160
 number 4160
 label 4160
 name 4160
 allow watch
!
!
ephone-dn  165
 number 4165
 label 4165
 name 4165
 allow watch
!
!
ephone-dn  170
 number 4170
 label 4170
 name 4170
 allow watch
!
!
ephone-dn  175
 number 4175
 label 4175
 name 4175
 allow watch
!
!
ephone-dn  180
 number 4180
 label 4180
 name 4180
 allow watch
!
!
ephone-dn  185
 number 4185
 label 4185
 name 4185
 allow watch
!
!
ephone-dn  190
 number 4190
 label 4190
 name 4190
 allow watch
!
!
ephone-dn  195
 number 4195
 label 4195
 name 4195
 allow watch
!
!
ephone  1
 device-security-mode none
 mac-address 001E.138C.A191
!
!
!
ephone  150
 device-security-mode none
 mac-address 0025.8416.BEE9
 type 7942
!
!
!
ephone  155
 device-security-mode none
 mac-address 0023.5E18.9B3F
 type 7942
!
!
!
!
line con 0
line aux 0
line vty 0 4
 privilege level 15
 logging synchronous
 transport input ssh
!
scheduler allocate 20000 1000
ntp master
ntp server 128.138.140.44
end

cme8.6#
Attachments:

3845路由器上的Cisco CCME 8.6无法正常工作 6 years 7 months ago #38523

看来我缺少一些文件?我确实运行了一个创建配置文件。这些文件是在那时创建的吗?

调试tftp
调试ccsip消息

5月1日18:08:56.347:TFTP:寻找CTLSEP00258416BEE9.tlv
5月1日18:08:56.419:TFTP:寻找ITLSEP00258416BEE9.tlv
5月1日18:08:56.487:TFTP:寻找ITLFile.tlv
5月1日18:08:56.727:TFTP:寻找SEP00258416BEE9.cnf.xml.sgn
5月1日18:08:56.851:TFTP:寻找XMLDefault.cnf.xml.sgn

3845路由器上的Cisco CCME 8.6无法正常工作 6 years 7 months ago #38524

krisarmstrong,

您是正确的-语音注册部分是SIP电话时,SCCP使用了ephone-dn。

虽然我认为自己遇到了问题,但我希望您验证以下内容:

1)确保CME为您的IP电话提供DHCP服务,并且“ 选项150 ip 10.250.0.57' 是正确的。
2)确保TFTP服务器文件语句正确,并且文件确实存在于CME的Flash中。
3)确保“电话服务'部分的配置正确"ip源地址"。我注意到你有" 10.250.0.249端口5080"但是你的DHCP服务有 10.250.0.57。我还建议您将端口留给标准 2000,至少在您的测试阶段。

如果以上任何一项都不起作用,请继续重置SCCP电话。我们在这里对此进行了深入介绍: www.firewall.cx/cisco-technical-knowledg...ipphone-upgrade.html

让我们知道您的结果!

祝好运!
克里斯。
克里斯·帕特塞尼迪斯
创办人兼总编辑
www.Firewall.cx
以下用户说谢谢: 克里斯阿姆斯特朗
  • 页:
  • 1
建立页面的时间:0.100秒

CCENT / CCNA

思科公司 路由器

  • SSL WebVPN
  • 保护路由器
  • 基于策略的路由
  • 棒上路由器

虚拟专用网 安全

  • 了解DMVPN
  • GRE / IPSec配置
  • 站点到站点IPSec 虚拟专用网
  • IPSec模式

思科公司 救命

  • 视窗 8 虚拟专用网 客户端
  • 视窗 7的VPN客户端
  • CCP显示问题
  • 思科支持应用程序。

视窗 2012

  • 新的功能
  • 发牌
  • Hyper-V / VDI
  • 安装Hyper-V

的Linux

  • 文件权限
  • Webmin
  • 群组-用户
  • Samba设置